Cara Pemesanan B2MA

Risalahmuslim.com memberikan kemudahan bagi siapa saja yang ingin belajar membaca alquran, kami memberikan solusi terbaik dengan system pengiriman program terlebih dahulu dan pembayaran donasi dibelakang ( Belajar Untuk Lebih baik,Jujur dan Bertanggung Jawab ) silahkan kirim data nama dan alamat lengkap anda ke No 085221805556 atau via email ke risalahmuslim@gmail.com Program B2MA akan segera kami kirim melalui PT POS INDONESIA Pembayaran donasi sebesar Rp.100.000 dapat dilakukan setelah paket Program B2MA diterima atau sampai di tempat tujuan.
Bank Central Asia ( BCA ) KCP Pasar Wetan atas nama Undang Muslim dengan no rekening 2090258438
Bank Syariah Mandiri atas nama Undang Muslim dengan no rekening 0527036687 (KODE BANK 541)
kami juga menerima weselpos dan western union.
Berilah tiga digit kode saat anda melakukan pembayaran agar bisa kami kenali.
Contoh Pembayaran Donasi :
Muhammad Iqbal Ambon Rp.100.215 tiga digit kode di belakang diambil dari ujung ponsel anda 085xxxxxx215
dan segera komfirm di no 085221805556 atau melalui email risalahmuslim@gmail.com

Hubungi Kami

Silahkan Hubungi
Undang Muslim
Kp:Leuwimalang Rt 02/03
Bantarsari,Bungursari,tasikmalaya 46151
Email : risalahmuslim@gmail.com
Home : 0265332695 call only
Handphone : +6285221805556 Call or Sms
Bank Central Asia ( BCA ) KCP Pasar Wetan atas nama Undang Muslim dengan no rekening 2090258438
Bank Syariah Mandiri cabang tasikmalaya a/n undang muslim
no rekening 0527036687 ( KODE BANK 541 )

Para Donatur B2MA

  • 93.  Yudi Suryawan Jl.Raya Pande Gg.Ki mahmud lemahabang,sindanglaut cirebon Program telah dikirim melalui POS INDONESIA =========================
  • 92.  M NUR IKHSAN DAMANIK Jl. H NANI WARTABONE no 28,gorontalo,gorontalo 96111 Program telah dikirim melalui POS INDONESIA =========================
  • 91.  Andika Suyata KPR Pepabri, Jl Kompleks Pepabri A4 No 5 Rt 04/07 Malaingkedi sorong papua barat 98415 Program telah dikirim melalui POS INDONESIA =========================
  • 90.  Muhammad Solihun Kauman ds selopangpang,selopangpang,temanggung56261 Program telah dikirim melalui POS INDONESIA =========================
  • 89.  Achmad Amirudin puri kencana blok K7 No 2E-F Jakarta barat 11610 Program telah dikirim melalui POS INDONESIA =========================
  • 88.  Muhammad Arif Santoso jl flamboyan IV no C1 kelurahan delima kecamatan tampan pekanbaru 28292 Program telah dikirim melalui POS INDONESIA =========================
  • 87.  DIDIK PRISTIWARSO Kantor Bupati Maluku Tengah Bagian Umum Setda Maluku Tengah Jl. Geser - Masohi Program telah dikirim melalui POS INDONESIA =========================
  • 86.  Muhammed Reza Jln. Keselamatan No.33 Rt : 12 Rw : 07 Kel : Krukut Kec: Tamansari Jakarta 11140 Program telah dikirim melalui POS INDONESIA =========================
  • 85.  Ari Wahyu Nugroho Jl.Sokasari No 18 Rt 02/07 sidorejolor,sidorejo salatiga 50714 Program telah dikirim melalui POS INDONESIA =========================
  • 84.  Bayu Kurniawan Jl. Yam Sabran No 100 Tanjung Hulu Rt. 02/02 No 100 Kelurahan Tanjung Hulu Pontianan Timur Kalimantan Barat Program telah dikirim melalui POS INDONESIA =========================
  • 83.  Esti Budiningrum Ruko Roxy Block C Lippo Cikarang Bekasi 17550 Program telah dikirim melalui POS INDONESIA =========================
  • 82.  Andri Mulya Jl.Pangeran Santri No.62 RT.01 RW.13 Kel Kota Kulon Kec Sumedang Kab Sumedang 45312 Program telah dikirim melalui POS INDONESIA =========================
  • 81.  Mauloof Ahmad 10, Batu 38 Kg Serting Tengah Seremban, Negeri Sembilan Program telah dikirim melalui email (link download ) =========================
  • 80.  SURAHMAN Jl. Gunung Amal Gang Cempaka1 Rt XI No 11 Tarakan Kaltim 77123 Program telah dikirim melalui POS INDONESIA =========================
  • 79.  Ibu Iin TK. DELLA FASHION Jl. Lintas Timur P. Reba Kec. Rengat Barat. RIAU Program telah dikirim melalui POS INDONESIA =========================
  • 78.  MUHAMMAD HIDAYAT MUHAMMAD HIDAYAT KPKNL Tarakan Jl. Diponogoro 188 Tarakan KALTIM Program telah dikirim melalui POS INDONESIA =========================
  • 77.  AGUSTINA PT. Rudaust Jl. Plumpang raya semper No 16 Tg Priok Jkt Utara 14230 Program telah dikirim melalui POS INDONESIA =========================
  • 76.  PANGAT Keboansikep,Gedangan sidoarjo Program telah dikirim melalui POS INDONESIA =========================
  • 75.  Mukhtar Sulawesi Program telah dikirim melalui POS INDONESIA =========================
  • 74.  Rofik Dhartomo PT.AKEBONO BRAKE ASTRA INDONESIA, Jl Pegangsaan dua blok A1 km 1.6 Kelapa gading, Jakarta utara telah dikirim melalui POS INDONESIA =========================
  • 73.  DAWAN SUHENDAR Perum Graha Mutiara B1/9 Kelurahan Kebon Agung Kecamatan Sukodono Sidoarjo-JATIM 61258 telah dikirim melalui POS INDONESIA =========================
  • 72.  Moh fihir jln pesarean kh.muhamad holil no 36 martajasah bangkalan madura 69117 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 71.  Riza Ali PT Inti Ganda Perdana Jl. Pegangsaan Dua KM 1,6 Kelapa Gading Jakarta Utara - 14250 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 70.  Khir Johari Bakar Malaysia B2MA edisi Spesial Link Download telah dikirim melalui email =========================
  • 69.  Nurwahidin Hasan Jl. Gardenia No 154 Rt 04 Panorama, Swarga Bara Sangatta 75611 KALTIM B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 68.  Herlin BPerumahan taman carina Blok 24 no 11 Kel.Tanjung Uncang -Batu aji Batam 29424 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 67.  Efandi Setiawan Bagian QA patrolman 2W PT.KAYABA INDONESIA Jl.Jawa Blok II No 4.Kawasan MM2100.Cikarang Barat B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 66.  Dedi Dulhikmat Jl Srigadis No 40 – Moch Ramdhan Bandung B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 65.  Drs. Imam Bustan Pramudia Edi,M.Si ( Hakim AdHoc Perikanan )Kantor Pengadilan Negri Kelas 1. A Tanjung Pinang Jl. Ahmad Yani No 29 Tanjung Pinang Propinsi KEPRI B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 64.  HENY SUKMAWATI PT. Neogennindo Perdana Jl. Pol. R.S. Sukanto No. 44 Pondok Kopi Jakarta Timur 13460 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 63.  RAYHANAH Jl. Mt haryono Kom. Posindo No 4 blok D Rt 38 balik papan 76121 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 62.  BOB HELMI Jl. Malikul Saleh I No 3 Lampineng, Banda Aceh Provinsi Aceh B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 61.  PURWANTO Jl. Letnan Arsyad no 14 A. Rt 02/016 kampung poncol Kel Kayuringinjaya bekasi selatan 17144 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 60.  Mukhtar Fattah S.Kom BTN Lino Maloga Blok B No. 3 Kel.Darma Kec. Polewali Kab.Polman Prov. Sulawesi Barat B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 59.  H.IRWAN HADIYANA MTs Al-Wishliyah Sukra Jl. Raya Sukra Kec.Sukra Indramayu 45257 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 58.  CHAIRANI LISTYAWITRI Rumah Sakit Pondok Indah Jl. Metro Duta KAV. UE Pondok Indah Jakarta Selatan 12310 B2MA edisi Spesial telah dikirim melalui POS INDONESIA =========================
  • 57.  WARNET FARIZ.NET B2MA edisi Ramadhan telah dikirim melalui ( Link download ) email =========================
  • 56.  SAMSUL ANIS ISMA'IL Malaysia via email B2MA edisi Ramadhan telah dikirim melalui ( Link download ) email =========================
  • 55.  M.SAFRIL Kantor PDAM TAKALAR Jl. B. Aminullah No 4 TAKALAR SULSEL 92221 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 54.  ATMA AGUS HERMAWAN Wartel & photo copy GUNUNG JATI Jl. Lingkar Dadaha Kel. Nagarawangi, kec.Cihideung Tasikmalaya B2MA edisi Ramadhan telah dikirim Langsung ke tempat =========================
  • 53.  MULYADI Puri Bugar Jl.Puri kencana blok.L6 No 1 Puri kembangan Jakarta Barat 11610 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 52.  AFRIZAL PAURASI trakindo utama jl.sukarno hatta no 36 pekan baru riau B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 51.  SUKANDAR jl.h.Yamin rt 03/01 no 86 petukangan utara jakarta 12260 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 50.  BATARA WISNU Komplek Karang Mas Indah RT 04 RW 14 Block B9 no:17 Desa Dawuan Tengah - Cikampek Karawang 41373 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 49.  SURYANI PD.MURNI JAYA MOTOR ( YAMAHA SABANGRAYA MOTOR ) Jl.Jendral Sudirman no 19 Rengas condong,muara bulian, Batang Hari,JAMBI 36613 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 48.  RUDIANSYAH Jl.Biawan Gg 2 Rt 11 no 40 Sidomulyo Samarinda Ilir KALTIM 75116 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 47.  EKO PRASETYO Jl Merpati no 524 Jayamukti Dumai Riau 28815 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 46.  WAHYUDI SPN Kupang, Jl Dodiklat no 6 oebobo kupang, nusa tenggara timur 85111 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 45.  M.ALI HASBI Jl.Krueng Petoe No 6 Meunasah Manyang Lhoksukon Aceh Utara B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 45.  ROSIDI.M KPP Pratama Pangkal pinang Jl. Taman ican saleh no.75 Pangkal Pinang Bangka 33121 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 44.  MOH.PADLIN FUAD Jl. Gagak Gg. Reuma kidul I No.23 Rt 02/19 Kel. Sadangserang Bandung 40133 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 43.  SRI SUKAMTI Perum Bumi Mutiara Indah Blok H7 no 15 Dawuan Tengah Kec. Cikampek Kab Karawaang 41373 Jawa Barat B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 42.  EDY RISTANTO Jl. Semeru III No 18 Griya Bukit Jaya Gn.Putri Bogor 16963 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 41.  ELLY Jl. Lukulo No 5 Kebumen 54311 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 40.  Sani Senoy Malaysia B2MA edisi Ramadhan telah dikirim Link Download melalui email =========================
  • 39.  YENY/GLEN Narogong Asri IV blok BA I no 1 Bekasi Timur B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 38.  THAHIR BAFHADAL KOM.BALAFKOP Jl.angkasa indah no 5a Jayapura PAPUA B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 38.  MOHAMMAD PAHLEVI Gedung International Financial Centre lt 9 Jl. jenderal sudirman kav 22-23 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 37.  SUHARIYADI Jl. Manukan Lor 6-C No. 6 Surabaya 60185 B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 36.  MUKSIN NASUTION PT. KARYA MUDA NASIONAL Madailing natal Sumatra Utara B2MA edisi Ramadhan telah dikirim melalui POS INDONESIA =========================
  • 35.  Budi Utoyo S.Psi Jl Perum Klipang Blok R XIV no 3 Semarang. B2MA edisi Ramadhan telah dikirim melalui JNE =========================
  • 34.  Roy Arief Aneka Pangan Mas Jl. Padat Karya no 74 cukang galih,curug Tangerang. Donasi Rp.85000,- telah dikirim melalui JNE
  • 33.  Ferry Permana Jln Leuwigajah,Cimuncang Cimahi selatan Donasi Rp.85000,- telah dikirim melalui TIKI
  • 32.  Ibu Asih Fitri Lawang,Malang Donasi Rp.85000,- telah dikirim melalui PT.POST INDONESIA
  • 31.  Hamid Sakti Wibowo Jln Bledak Kantil Perumnas Tlogosarri Semarang Donasi Rp.85000,- telah dikirim melalui PT.POS INDONESIA
  • 30.  Rasita Perumahan IndoGriya klangenan Cirebon Donasi Rp.85000,- telah dikirim melalui PT.POS INDONESIA
  • 29.  Dewi Kurniasari Pengadilan Negri Salatiga Donasi Rp.120.000,- telah dikirim melalui PT.TIKI
  • 28.  Guntur Purnomo Jl. A.P. Pettarani Makassar, Sulawesi Selatan. Donasi Rp.100.000,- telah dikirim melalui PT.POS INDONESIA
  • 27.  IR. ZULKIFLI SIMBOLON PT.Lonsum Balombissie Estate Makassar,Sulawesi Selatan. Donasi $ 10.00 via paypal telah dikirim melalui PT. POS INDONESIA
  • 26.  Sita Purwanti Jl.Almubarok 2 no 21 cipulir,kebayoran lama Jakarta Selatan " Paket sudah sampai..! mohon bantuan do'a nya agar allah mudahkan proses belajar saya terimakasih."
  • 25.  Rizal Setyadi Jl.Antena komplek bea cukai ( laut ) Kec.Meral Tanjung balai Kepulawan Riau
  • 24.  Herman Gunawan Dept,information dan technologi PT INFOMEDIA NUSANTARA Jl RS FATMAWATI Jakarta Selatan
  • 23.  Roli Hidayat SPBU 14.241.413 ulee gle Banda Aceh. "Terimakasih Banyak Pak Muslim Mudah mudahan saya bisa belajar Dari Program Bapak "
  • 22.  Nanang Firmansyah Jl. Simpang Pinus no.26 Rt 03/05 mentaos banjarbaru kalimantan selatan.
  • 21.  Musfiar PLN Ranting sungai rumbai Sumatra Barat " Alhamdulillah Program telah sampai di tangan saya dan mudah-mudahan kita terus berlanjut dengan menjalin ukhuah amin."
  • 20.  Ali Imran Jl Pertahanan Sigara-gara patumbak deliserdang medan " Alhamdulillah kirimannya sudah di ambil di medan "
  • 19.  Andy Mulyanto Prima Harapan Regency Bekasi "Asmkm,alhamdulillah kirimannya sudah sampai Pak."
  • 18.  Ibu sri Mulyati Komplek mabes polri Tangerang " Asmkm,alhamdulillah kirimannya sudah sampai Pak,jelas dan lengkap.Mks ya Pak"
  • 17.  Bapak Muhammad Nur Kalimantan Tengah Terimakasih kiriman sudah Kami terima
  • 16.  Bapak Banjar Banjar,ciamis jawa barat Langsung silaturahim ke rumah
  • 15.  Bapak Rifal Kantor PDAM Kab.Luwu timur Jl. Lahadeng Kec. Malili Sulawesi selatan Saya telah transfer uang sebesar Rp 100.000 mohon link downloadnya agar cepat dipelajari terimakasih.
  • 14.  Bapak Yuria Hefni Perum Kinanti Asri no1 ganjuran sleman yogyakarta uang telah di transfer sebesar Rp 85000 mohon program B2MA nya dikirim terimakasih.
  • 13.  Riyanda Zulkarni Kantor Pengawasan dan Pelayanan Bea dan Cukai Bontang Kalimantan Timur. Terimakasih Mas programnya telah sampai dan berhasil dijalankan di windows
  • 12.  Andrea Prakoso Pamulang Permai 1 Blok BX 9 No.5 Ciputat Tangerang 15417 Pak...Paket udah ana terima terimakasih
  • 11.  Sachi Aina via email Donasi Rp.80.000 Telah dikirim Link download sesuai permintaannya.
  • 10.  R.Dede sumpena PT.Manggala IndoPratama Jl.Taman Kaliandra no 14 komplek taman sakura Bandung ass.wr.wb... Pak muslim saya telah terima paket yg bpk kirim dan sudah mencoba program B2MA,alhamdulillah Program Berjalan Baik di komputer saya.Terimakasih Semoga segala Usaha dan Ilmu yg telah bpk berikan mendapat rahmat dan ganjaran pahala yg berlipat dari allah SWT,serta bermanfaat khususnya utk saya dan keluarga.amin.saya berharap bapak terus berkarya dan saya tunggu inovasi2 konten islam selanjutnya drbpk.wassalam.....
  • 9.  Izwandi Abdullah taman setapak indah setapak, kuala lumpur Malaysia Salam, Saya mengucapkan ribuan terima kasih kepada Pak Muslim kerna nigrim download link nya. Soalan saya...adakah saya bisa menguasai bacaan Al-Quran secepat mungkin dengan hanya melalui pembelajran B2MA selama 1 jam sehari jika difokuskan selama 1 bulan? Untuk makluman Pak Muslim, saya seorang yang buta huruf Al-Quran.
  • 8.  Beny Kusumobroto Perumahan PAMA Block D III karang asam,tanjung enim,muara enim,SUMSEL. Bos programnya Telah sampai dan berhasil RUN...terimakasih.
  • 7.  Fitri is wulandari PT.INTRASARI RAYA ngaran,ceper ( KLATEN ) Terimakasih pak Programnya Telah sampai...
  • 6.  Arief Malaysia Donasi Rp 100.000 Telah dikirim melalui Link download
  • 5.  Dewasa sidik Sabah,Malaysia Donasi $8.00 USD melalui Paypal Telah dikirim melalui Link download
  • 4.  Inawan Banjar, ciamis Silaturahim kerumah tasikmalaya
  • 3.  Muhammad Iqbal Talanaipura,Jambi terimakasih programnya telah sampai.
  • 2. Lupa namanya RS LNG Badak,Bontang Kaltim terimakasih programnya telah sampai.
  • 1.  Lupa namanya dan Banten,Jawa barat terimakasih programnya telah sampai. semoga program ini membawa manfaat amin.

Pengumuman

cd dan dvd yang kami kelola masih menggunakan system burning, dan bagi para agen yang memesan program banyak dengan system pabrikasi mohon maaf ada beberapa alasan sehingga kami tidak bisa melayani, sementara disini kami hanya melayani perorangan Terimakasih. ====================================== Kami tidak menjual program ini atau tidak meng-komersilkan program ini,atau memasarkan di toko-toko terkemuka. Kami hanya meminta donasi bagi yang mampu untuk biaya pengembangan program ini dan sebagai pengganti biaya pengepakan serta ongkos kirim.

Donasi Melalui

Photobucket
Photobucket
Photobucket
Photobucket
Donate $15

Tentang B2MA

Kami sengaja membuat sebuah apikasi belajar membaca al-quran diperuntukan bagi pemula kelebihannya:
1.Mudah di pahami
2.Mudah di pelajari
3.tidak perlu instalasi
4.menggunakan system autorun
5.ramah komputer pentium II pun bisa
6.Donation ware.
Hubungi Kami

Nuance PDF Converter Enterprise Review risalahmuslim


Risalahmuslim.com Nuance PDF Converter Enterprise merupakan salah satu software atau aplikasi PDF yang sangat powerful untuk membuat, mengedit, meng konversi (convert) dan share dengan kolega atau konsumen. terutama bagi anda yang gemar membuat ebook
PDF Converter Enterprise 7 is powerful, intelligent PDF software that enables businesses to create, convert, edit, assemble and share PDF files with colleagues or customers.
Silahkan anda bisa mencobanya langsung disitus aslinya dan mencoba versi trialnya ketimbang meng-crack yang mengakibatkan system pc anda terserang virus, langsung saja unduh disitus resminya disini. Semoga bermanfaat Aamiin.

Aimersoft Video Converter Ultimate review risalahmuslim

Assalamu'alaikum, lama tidak posting blog ditinggalkan begitu saja entah dua atau tiga tahun hingga page rank 2 menjadi 0 NOL :( , karena suatu kesibukan memang, tapi saya pikir sayang juga jika ditinggalkan begitu saja th dirumah ada juga sela-sela waktu walau sekedar sharing atau posting satu hari satu kali masih bisa  itu juga kalau penyakit malas tidak kambuh :).
Bismillahir rahmanir rahim insya Allah blog ini akan di kelola kembali dengan materi sharing dan review beberapa software dll.

scuid.conf

# WELCOME TO SQUID LUSCA_FMI
# ----------------------------
# Provided by mr-ekoapriadi.blogspot.com
# last revision 26/06/2013

http_port 3128 transparent
#==============================================================#
pid_filename /var/run/squid.pid
cache_effective_user proxy
cache_effective_group proxy
error_directory /usr/share/squid/errors/English
icon_directory /usr/share/squid/icons
visible_hostname www.mr-ekoapriadi.blogspot.com
cache_mgr mr.ekoapriadi@gmail.com
access_log /var/log/squid/access.log
cache_log /var/log/squid/cache.log
cache_store_log none
logfile_rotate 1
shutdown_lifetime 10 seconds
cache_mem 8 MB
maximum_object_size_in_memory 32 KB
memory_replacement_policy heap GDSF
cache_replacement_policy heap LFUDA

#==============================================================#
cache_dir aufs /cache 15000 35 256

#CONTOH  DNS GOOGLE
dns_nameservers 8.8.8.8 8.8.4.4
#==============================================================#

dns_testnames 127.0.0.1
minimum_object_size 128 bytes
maximum_object_size 128000 KB
offline_mode off
cache_swap_low 98
cache_swap_high 99
# Setup some default acls
acl all src 0.0.0.0/0.0.0.0
acl localhost src 127.0.0.1/255.255.255.255
acl safeports port 21 70 80 210 280 443 488 563 591 631 777 901 81 3128 1025-65535
acl sslports port 443 563 81
acl manager proto cache_object
acl purge method PURGE
acl connect method CONNECT
acl dynamic urlpath_regex cgi-bin \?
acl snmppublic snmp_community public
acl shoutcast rep_header X-HTTP09-First-Line ^ICY.[0-9]
acl apache rep_header Server ^Apache

#==============================================================#
#acl blockweb url_regex "/etc/squid/block.txt"
#http_access deny blockweb
#==============================================================#
acl localnet src 192.168.1.0/16 # RFC1918 possible internal network

#==============================================================#
#start storeurl htproxy
#==============================================================#
acl store_rewrite_list dstdomain .fbcdn.net .youtube.com .googlevideo.com  .gstatic.com .bp.blogspot.com
acl store_rewrite_list dstdomain .4shared.com .twimg.com .ytimg.com .orkut.com
acl store_rewrite_list dstdomain .ggpht.com .media.tumblr.com .photobucket.com
acl store_rewrite_list dstdomain .avast.com .avg.com .vimeo.com .v.mccont.com .blip.tv
acl store_rewrite_list dstdomain .flashvideo.globo.com .terra.com
acl store_rewrite_list dstdomain .wpc.porntube.com .redtubefiles.com .xvideos.com .phncdn.com .pornhub.com
acl store_rewrite_list dstdomain .catalog.video.msn.com .mais.uol.com.br
acl store_rewrite_list dstdomain .videobb.com .sourceforge.net
acl store_rewrite_list_url url_regex (firefox|speedtest|iavs5x|iavs4x)


acl dontrewrite url_regex (get_video|videoplayback\?id|videoplayback.*id).*begin\=[1-9][0-9]*
acl dontrewrite url_regex \.(php|asp|aspx|jsp|cgi|js)\?
acl dontrewrite url_regex threadless.*\.jpg\?r=
storeurl_access deny dontrewrite
storeurl_access allow store_rewrite_list
storeurl_access allow store_rewrite_list_url
storeurl_access deny all

storeurl_access deny all
storeurl_rewrite_program  /etc/squid/storeurl.pl
storeurl_rewrite_children 1

#==============================================================#
#end storeurl acl

#==============================================================#
broken_vary_encoding allow apache
upgrade_http0.9 deny shoutcast
http_access allow manager localhost
http_access deny manager
http_access allow purge localhost
http_access deny purge
http_access deny !safeports
http_access deny CONNECT !sslports

# Always allow localhost connections
http_access allow localhost

# Allow local network(s) on interface(s)
http_access allow localnet

# Default block all to be sure
http_access deny all
#==============================================================#
#REFRESH PATTERN TUNNING
#==============================================================#
#Spesific Site
refresh_pattern ^http://([a-z][0-9]\.){0,1}(profile|sphotos|photos-[a-z])\.ak\.fbcdn\.net/hp(rofile|hotos)-ak- 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://[^/]*\.(youtube|googlevideo).com/(get_video|videoplayback|videodownload)\? 5259487 99999% 5259487 override-expire ignore-reload  reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://lh.\.ggpht\.com/.*\.(bmp|gif|jpg|png) 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://i.\.ytimg\.com/.*\.(bmp|gif|jpg|png) 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://a.\.twtimg\.com/.*\.(bmp|gif|jpg|png) 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://(.{1,2}\.|)media\.tumblr\.com/.*\.(bmp|gif|jpg|png) 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://(i|th).{1,4}\.photobucket\.com/.*\.(bmp|gif|jpg|png) 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://[1-4]\.bp\.blogspot\.com/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://download.*\.avast\.com/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://download.*\.4shared\.com/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://(backup|a.|pupdate-aa)\.avg\.c(om|z)/softw/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://av\.vimeo\.com/.*\.(mp4|flv) 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://.{1,3}\.video.\.blip\.tv.*\.(m4v|flv|mp4|wmv|rm|ram|mov|avi|mp3) 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://flashvideo.globo.com/.*mp4 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://(img|content).{1,2}.catalog.video.msn.com/ 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://(video.{1,2}|thumb|storage)\.mais\.uol\.com.br/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://v.mccont.com/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://(img..|videos\.flv.{0,1})\.redtubefiles\.com/ 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache
refresh_pattern ^http://wpc.porntube.com/ 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://porn.{1,3}\.xvideos\.com/.*\.flv 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://s[0-9]{0,3}\.videobb\.com/ 5259487 99999% 5259487 override-expire ignore-reload stale-while-revalidate=2592000 ignore-private ignore-no-cache store-stale
refresh_pattern ^http://t.\.gstatic\.com/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache
refresh_pattern ^http://cdn[1-3][a-z]{0,1}.*\.phncdn\.com/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache
refresh_pattern ^http://nyc-v[0-9]{1,3}\.pornhub\.com/*\.flv 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache
refresh_pattern ^http://[a-z]{1,}\.dl\.sourceforge\.net\/project/ 5259487 99999% 5259487 override-expire reload-into-ims stale-while-revalidate=2592000 ignore-private ignore-no-cache
refresh_pattern (speedtest|firefox) 5259487 99999% 5259487 override-expire override-expire reload-into-ims ignore-must-revalidate ignore-private ignore-no-cache store-stale

#Generic files
refresh_pattern \.(jp(e?g|e|2)|tiff?|bmp|gif|png) 2629742 999999% 2629742 override-expire ignore-no-cache ignore-no-store reload-into-ims ignore-private store-stale
refresh_pattern \.(z(ip|[0-9]{2})|r(ar|[0-9]{2})|jar|bz2|gz|tar|rpm|vpu)  2629742 999999% 2629742 override-expire reload-into-ims store-stale ignore-must-revalidate
refresh_pattern \.(mp3|wav|og(g|a)|flac|midi?|rm|aac|wma|mka|ape) 2629742 999999% 2629742 override-expire reload-into-ims ignore-reload ignore-must-revalidate store-stale
refresh_pattern \.(kom|nzp|iop|exe|msi|dmg|bin|xpi|iso|swf|mar|psf|cab) 2629742 999999% 2629742 override-expire reload-into-ims ignore-no-cache ignore-must-revalidate store-stale
refresh_pattern \.(mpeg|ra?m|avi|mp(g|e|4)|mov|divx|asf|wmv|m\dv|rv|vob|asx|ogm|flv|3gp|on2) 2629742 9999999% 2629742 override-expire reload-into-ims ignore-must-revalidate  ignore-private  ignore-no-store store-stale
refresh_pattern -i (cgi-bin|hackshield|xtrap|Loader|login) 0 0% 0
refresh_pattern \.(php|jsp|cgi|asx|js|jsp)\? 0 0% 0
refresh_pattern . 0 50% 2629742 store-stale
#==============================================================#
acl download url_regex -i \.rm$ \.mpg$ \.mpeg$ \.avi$ \.dat$ \.exe$ \.vqf$ \.tar.gz$ \.gz$ \.rpm$ \.mp4$ \.mp3$
acl download url_regex -i \.zip$ \.bz2$ \.rar$ \.qt$ \.ram$ \.rm$ \.iso$ \.raw$ \.wav$ \.mov$ \.cab$
acl download url_regex -i \.rhz$ \.dat$ \.hlp$ \.psf$ \.exe$ \.bin$ \.cab$ \.amr$ \.msi$ \.dll$

delay_pools 1
delay_class 1 1
delay_parameters 1 1000/16000
delay_access 1 allow download
delay_access 1 deny ALL
#==============================================================#
#flow qos mark HIT
zph_mode tos
zph_local 0x30
zph_parent 0
zph_option 136

#SNMP enable  for MRTG
snmp_port 3401
snmp_access allow snmppublic all

#Option Tunning
max_filedescriptors 65536
range_offset_limit 128 KB
read_ahead_gap 32 KB
reload_into_ims on
strip_query_terms on
negative_dns_ttl 1 second
negative_ttl 1 second
maximum_single_addr_tries 2
retry_on_error on
vary_ignore_expire on
client_db on
ipcache_size 10240
fqdncache_size 1024
pipeline_prefetch on
half_closed_clients off
buffered_logs on
download_fastest_client_speed off
n_aiops_threads 32

Storeurl.pl

#!/usr/bin/perl
# mr.ekoapriadi@yahoo.com
# Edit By: Eko Apriadi, S.Kom.

$|=1;
while (<>) {
    @X = split;
    # $X[1] =~ s/&sig=.*//;
    $x = $X[0] . " ";
    $_ = $X[1];
    $u = $X[1];

if ($X[1] =~ /(youtube|google).*videoplayback\?/){
    @itag = m/[&?](itag=[0-9]*)/;
    @id = m/[&?](id=[^\&]*)/;
    @range = m/[&?](range=[^\&\s]*)/;
    @begin = m/[&?](begin=[^\&\s]*)/;
    @redirect = m/[&?](redirect_counter=[^\&]*)/;
    print $x . "http://video-srv.youtube.com.SQUIDINTERNAL/@itag&@id&@range@begin@redirect\n";


# youtube HD itag=22
} elsif (m/^http:\/\/([0-9.]{4}|.*\.youtube\.com|.*\.googlevideo\.com|.*\.video\.google\.com).*?\&(itag=22).*?\&(id=[a-zA-Z0-9]*)/) {
    print $x . "http://video-srv.youtube.com.SQUIDINTERNAL/" . $2 . "&" . $3 . "\n";

# youtube Normal screen always HD itag 35, Normal screen never HD itag 34, itag=18 <--normal br=""> } elsif (m/^http:\/\/([0-9.]{4}|.*\.youtube\.com|.*\.googlevideo\.com|.*\.video\.google\.com).*?\&(itag=[0-9]*).*?\&(id=[a-zA-Z0-9]*)/) {
    print $x . "http://video-srv.youtube.com.SQUIDINTERNAL/" . $3 . "\n";

# speedtest
} elsif (m/^http:\/\/(.*)\/speedtest\/(.*\.(jpg|txt))\?(.*)/) {
    print $x . "http://www.speedtest.net.SQUIDINTERNAL/speedtest/" . $2 . "\n";

# mediafire
} elsif (m/^http:\/\/199\.91\.15\d\.\d*\/\w{12}\/(\w*)\/(.*)/) {
    print $x . "http://www.mediafire.com.SQUIDINTERNAL/" . $1 ."/" . $2 . "\n";

# fileserve
} elsif (m/^http:\/\/fs\w*\.fileserve\.com\/file\/(\w*)\/[\w-]*\.\/(.*)/) {
    print $x . "http://www.fileserve.com.SQUIDINTERNAL/" . $1 . "./" . $2 . "\n";

# filesonic
} elsif (m/^http:\/\/s[0-9]*\.filesonic\.com\/download\/([0-9]*)\/(.*)/) {
    print $x . "http://www.filesonic.com.SQUIDINTERNAL/" . $1 . "\n";

# 4shared
} elsif (m/^http:\/\/[a-zA-Z]{2}\d*\.4shared\.com(:8080|)\/download\/(.*)\/(.*\..*)\?.*/) {
    print $x . "http://www.4shared.com.SQUIDINTERNAL/download/$2\/$3\n";

# 4shared preview
} elsif (m/^http:\/\/[a-zA-Z]{2}\d*\.4shared\.com(:8080|)\/img\/(\d*)\/\w*\/dlink__2Fdownload_2F(\w*)_3Ftsid_3D[\w-]*\/preview\.mp3\?sId=\w*/) {
    print $x . "http://www.4shared.com.SQUIDINTERNAL/$2\n";

# photos-X.ak.fbcdn.net where X a-z
} elsif (m/^http:\/\/photos-[a-z](\.ak\.fbcdn\.net)(\/.*\/)(.*\.jpg)/) {
    print $x . "http://photos" . $1 . "/" . $2 . $3  . "\n";

# YX.sphotos.ak.fbcdn.net where X 1-9, Y a-z
} elsif (m/^http:\/\/[a-z][0-9]\.sphotos\.ak\.fbcdn\.net\/(.*)\/(.*)/) {
    print $x . "http://photos.ak.fbcdn.net/" . $1  ."/". $2 . "\n";

# maps.google.com
} elsif (m/^http:\/\/(cbk|mt|khm|mlt|tbn)[0-9]?(.google\.co(m|\.uk|\.id).*)/) {
    print $x . "http://" . $1  . $2 . "\n";

# compatibility for old cached get_video?video_id
} elsif (m/^http:\/\/([0-9.]{4}|.*\.youtube\.com|.*\.googlevideo\.com|.*\.video\.google\.com).*?(videoplayback\?id=.*?|video_id=.*?)\&(.*?)/) {
    $z = $2; $z =~ s/video_id=/get_video?video_id=/;
    print $x . "http://video-srv.youtube.com.SQUIDINTERNAL/" . $z . "\n";

} elsif (m/^http:\/\/www\.google-analytics\.com\/__utm\.gif\?.*/) {
    print $x . "http://www.google-analytics.com/__utm.gif\n";

#Cache High Latency Ads
} elsif (m/^http:\/\/([a-z0-9.]*)(\.doubleclick\.net|\.quantserve\.com|\.googlesyndication\.com|yieldmanager|cpxinteractive)(.*)/) {
    $y = $3;$z = $2;
    for ($y) {
    s/pixel;.*/pixel/;
    s/activity;.*/activity/;
    s/(imgad[^&]*).*/\1/;
    s/;ord=[?0-9]*//;
    s/;&timestamp=[0-9]*//;
    s/[&?]correlator=[0-9]*//;
    s/&cookie=[^&]*//;
    s/&ga_hid=[^&]*//;
    s/&ga_vid=[^&]*//;
    s/&ga_sid=[^&]*//;
    # s/&prev_slotnames=[^&]*//
    # s/&u_his=[^&]*//;
    s/&dt=[^&]*//;
    s/&dtd=[^&]*//;
    s/&lmt=[^&]*//;
    s/(&alternate_ad_url=http%3A%2F%2F[^(%2F)]*)[^&]*/\1/;
    s/(&url=http%3A%2F%2F[^(%2F)]*)[^&]*/\1/;
    s/(&ref=http%3A%2F%2F[^(%2F)]*)[^&]*/\1/;
    s/(&cookie=http%3A%2F%2F[^(%2F)]*)[^&]*/\1/;
    s/[;&?]ord=[?0-9]*//;
    s/[;&]mpvid=[^&;]*//;
    s/&xpc=[^&]*//;
    # yieldmanager
    s/\?clickTag=[^&]*//;
    s/&u=[^&]*//;
    s/&slotname=[^&]*//;
    s/&page_slots=[^&]*//;
    }
    print $x . "http://" . $1 . $2 . $y . "\n";

# cache high latency ads
} elsif (m/^http:\/\/(.*?)\/(ads)\?(.*?)/) {
    print $x . "http://" . $1 . "/" . $2  . "\n";

# spicific servers starts here....
} elsif (m/^http:\/\/(www\.ziddu\.com.*\.[^\/]{3,4})\/(.*?)/) {
    print $x . "http://" . $1 . "\n";

# cdn, varialble 1st path
} elsif (($u =~ /filehippo/) && (m/^http:\/\/(.*?)\.(.*?)\/(.*?)\/(.*)\.([a-z0-9]{3,4})(\?.*)?/)) {
    @y = ($1,$2,$4,$5);
    $y[0] =~ s/[a-z0-9]{2,5}/cdn./;
    print $x . "http://" . $y[0] . $y[1] . "/" . $y[2] . "." . $y[3] . "\n";

# rapidshare
} elsif (($u =~ /rapidshare/) && (m/^http:\/\/(([A-Za-z]+[0-9-.]+)*?)([a-z]*\.[^\/]{3}\/[a-z]*\/[0-9]*)\/(.*?)\/([^\/\?\&]{4,})$/)) {
    print $x . "http://cdn." . $3 . "/SQUIDINTERNAL/" . $5 . "\n";

} elsif (($u =~ /maxporn/) && (m/^http:\/\/([^\/]*?)\/(.*?)\/([^\/]*?)(\?.*)?$/)) {
    print $x . "http://" . $1 . "/SQUIDINTERNAL/" . $3 . "\n";

# like porn hub variables url and center part of the path, filename etention 3 or 4 with or without ? at the end
} elsif (($u =~ /tube8|pornhub|xvideos/) && (m/^http:\/\/(([A-Za-z]+[0-9-.]+)*?(\.[a-z]*)?)\.([a-z]*[0-9]?\.[^\/]{3}\/[a-z]*)(.*?)((\/[a-z]*)?(\/[^\/]*){4}\.[^\/\?]{3,4})(\?.*)?$/)) {
    print $x . "http://cdn." . $4 . $6 . "\n";
    #...spicific servers end here.

# photos-X.ak.fbcdn.net where X a-z
} elsif (m/^http:\/\/photos-[a-z].ak.fbcdn.net\/(.*)/) {
    print $x . "http://photos.ak.fbcdn.net/" . $1  . "\n";

# for yimg.com video
} elsif (m/^http:\/\/(.*yimg.com)\/\/(.*)\/([^\/\?\&]*\/[^\/\?\&]*\.[^\/\?\&]{3,4})(\?.*)?$/) {
    print $x . "http://cdn.yimg.com//" . $3 . "\n";

# for yimg.com doubled
} elsif (m/^http:\/\/(.*?)\.yimg\.com\/(.*?)\.yimg\.com\/(.*?)\?(.*)/) {
    print $x . "http://cdn.yimg.com/"  . $3 . "\n";

# for yimg.com with &sig=
} elsif (m/^http:\/\/(.*?)\.yimg\.com\/(.*)/) {
    @y = ($1,$2);
    $y[0] =~ s/[a-z]+[0-9]+/cdn/;
    $y[1] =~ s/&sig=.*//;
    print $x . "http://" . $y[0] . ".yimg.com/"  . $y[1] . "\n";

# youjizz. We use only domain and filename
} elsif (($u =~ /media[0-9]{2,5}\.youjizz/) && (m/^http:\/\/(.*)(\.[^\.\-]*?\..*?)\/(.*)\/([^\/\?\&]*)\.([^\/\?\&]{3,4})((\?|\%).*)?$/)) {
    @y = ($1,$2,$4,$5);
    $y[0] =~ s/(([a-zA-A]+[0-9]+(-[a-zA-Z])?$)|(.*cdn.*)|(.*cache.*))/cdn/;
    print $x . "http://" . $y[0] . $y[1] . "/" . $y[2] . "." . $y[3] . "\n";

# general purpose for cdn servers. add above your specific servers.
    } elsif (m/^http:\/\/([0-9.]*?)\/\/(.*?)\.(.*)\?(.*?)/) {
    print $x . "http://squid-cdn-url//" . $2  . "." . $3 . "\n";

# generic http://variable.domain.com/path/filename."ex" "ext" or "exte" with or withour "? or %"
    } elsif (m/^http:\/\/(.*)(\.[^\.\-]*?\..*?)\/(.*)\.([^\/\?\&]{2,4})((\?|\%).*)?$/) {
    @y = ($1,$2,$3,$4);
    $y[0] =~ s/(([a-zA-A]+[0-9]+(-[a-zA-Z])?$)|(.*cdn.*)|(.*cache.*))/cdn/;
    print $x . "http://" . $y[0] . $y[1] . "/" . $y[2] . "." . $y[3] . "\n";

# generic http://variable.domain.com/...
    } elsif (m/^http:\/\/(([A-Za-z]+[0-9-]+)*?|.*cdn.*|.*cache.*)\.(.*?)\.(.*?)\/(.*)$/) {
    print $x . "http://cdn." . $3 . "." . $4 . "/" . $5 .  "\n";

# spicific extention that ends with ?
    } elsif (m/^http:\/\/(.*?)\/(.*?)\.(jp(e?g|e|2)|gif|png|tiff?|bmp|ico|flv|wmv|3gp|mp(4|3)|exe|msi|zip|on2|mar|rar|cab|amf|swf)(.*)/) {
    print $x . "http://" . $1 . "/" . $2  . "." . $3 . "\n";

# all that ends with ;
    } elsif (m/^http:\/\/(.*?)\/(.*?)\;(.*)/) {
    print $x . "http://" . $1 . "/" . $2  . "\n";

} else {
    print $x . $_ . "sucks\n";
}
}

Server Hight Performa ubunu server proxy lusca + configurasi microtik

[SERVER] High Performance Cache HIT Proxy Lusca on Ubuntu Server + Configurasi Router MikroTik

High Performance Cache HIT Proxy Lusca on Ubuntu Server + Configurasi Router MikroTik

Video Install Ubuntu Server 10.04 and use Manual Partition 


1. Paket Install yang di Butuhkan:
root@proxy:~# apt-get update
root@proxy:~# apt-get install squid -y
root@proxy:~# apt-get install squid squidclient squid-cgi -y
root@proxy:~# apt-get install gcc -y
root@proxy:~# apt-get install build-essential -y
root@proxy:~# apt-get install sharutils -y
root@proxy:~# apt-get install ccze -y
root@proxy:~# apt-get install libzip-dev -y
root@proxy:~# apt-get install automake1.9 -y

2. Download File LUSCA_LUSCA.tar.gz dengan cara sebagai berikut:

root@proxy:~# wget https://proxy-ku.googlecode.com/files/LUSCA_FMI.tar.gz
root@proxy:~# tar xzvf LUSCA_FMI.tar.gz
root@proxy:~# cd LUSCA_FMI

3. Perintah Install Compile File LUSCA_FMI

./configure --prefix=/usr --exec_prefix=/usr --bindir=/usr/sbin --sbindir=/usr/sbin --libexecdir=/usr/lib/squid --sysconfdir=/etc/squid --localstatedir=/var/spool/squid --datadir=/usr/share/squid --enable-http-gzip --enable-async-io=24 --with-aufs-threads=24 --with-pthreads --enable-storeio=aufs --enable-linux-netfilter --enable-arp-acl --enable-epoll --enable-removal-policies=heap --with-aio --with-dl --enable-snmp --enable-delay-pools --enable-htcp --enable-cache-digests --disable-unlinkd --enable-large-cache-files --with-large-files --enable-err-languages=English --enable-default-err-language=English --with-maxfd=65536 && make && make install

4. Setelah Compile File LUSCA_FMI Buatlah Direktori Cache:
root@proxy:~# mkdir cache-1
root@proxy:~# mkdir cache-2
5. Kemudian diberi lebel proxy:proxy dan di beri permision:
root@proxy:~# chown proxy:proxy /cache-1
root@proxy:~# chown proxy:proxy /cache-2
6. Kemudain di beri permision:
root@proxy:~# chmod 777 /cache-1
root@proxy:~# chmod 777 /cache-2

7. Setelah selesai anda Download File >>--> squid.conf
root@proxy:~# chown proxy:proxy /etc/squid/squid.conf
root@proxy:~# chmod 777 /etc/squid/squid.conf 

8. Kemudian Buat Listing File storeurl Sebelumnya Download File >>-->  storeurl.pl
root@proxy:~# touch /etc/squid/storeurl.pl
root@proxy:~# chown proxy:proxy /etc/squid/storeurl.pl
root@proxy:~# chmod 777 /etc/squid/storeurl.pl

9. Buka storeurl.pl dengan winscp dan isikan dengan Script storeurl.pl yang telah anda download

Kemudian pada menu Terminal pada software putty ketik " /etc/init.d/squid stop "
Masih pada menu Terminal pada software , copy-paste perintah di bawah satu-persatu

root@proxy:~# /etc/init.d/squid restart

10. Restart Komputer Kamu
Monitoring Squid access.log :

root@proxy:~# tail -f /var/log/squid/access.log | ccze


Descriptions...
=========================
PAKET INSTALL TAMBAHAN
=========================

Kalau sudah selesai anda setting mikrotiknya seperti dibawah ini :
Masukkan ini di mangle :

;;; Intl-conn
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=packet-intl passthrough=no
/ip firewall mangle add chain=output action=mark-packet new-packet-mark=packet-intl passthrough=no

;;; PROXY-HIT
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=proxy-hit passthrough=no dscp=12

;;; http-conn
/ip firewall mangle add chain=prerouting action=mark-connection new-connection-mark=http-conn passthrough=yes protocol=tcp dst-port=80
/ip firewall mangle add chain=prerouting action=mark-packet new-packet-mark=http passthrough=yes connection-mark=http-conn

;;; https-conn
/ip firewall mangle add chain=prerouting action=mark-connection new-connection-mark=https-conn passthrough=yes connection-state=new protocol=tcp dst-port=443
/ip firewall mangle add chain=prerouting action=mark-routing new-routing-mark=https passthrough=no connection-mark=https-conn

;;; CHANGE MMS
/ip firewall mangle add chain=forward action=change-mss new-mss=1440 tcp-flags=syn protocol=tcp in-interface=public tcp-mss=1441-65535

IP FIREWALL ADDRESS-LIST :
;;; LocalNet
LocalNet     192.168.2.0/24     — IP local sesuaikan dengan IP lokal anda

;;; PROXY
ProxyNet     192.168.2.0/24 -- IP network Proxy
DNS             202.134.1.10     -- sesuaikan DNS ISP anda
DNS             202.134.0.155     -- sesuaikan DNS ISP anda
GAMES           63.241.101.0/25
GAMES           74.114.8.0/21

IP FIREWALL NAT :
;;; Nat Proxy
/ip firewall add chain=dstnat action=dst-nat to-addresses=192.168.2.20 to-ports=3128 protocol=tcp src-address=!192.168.2.20 src-address-list=LocalNet dst-address-list=!ProxyNet dst-port=80,8080,3128
connection-mark=http-conn

;;; Added by webbox
/ip firewall add chain=srcnat action=masquerade out-interface=ether1-gateway

;;; Proxy Out
/ip firewall add chain=srcnat action=src-nat to-addresses=IP INTERNET ANDA/IP PUBLIC misalnya 192.168.1.2 src-address=IP LOKAL ANDA misalnya 192.168.2.1
/ip firewall add chain=dstnat action=dst-nat to-ports=53 protocol=udp dst-port=53

;;; SSH
/ip firewall add chain=dstnat action=dst-nat to-addresses=192.168.1.2 to-ports=22 protocol=tcp dst-address=IP INTERNET ANDA/IP PUBLIC dst-port=22,10000

;;; queue tree
/queue tree add name="A_HIT-Proxy" parent=lan packet-mark=proxy-hit limit-at=0 queue=default priority=8 max-limit=0 burst-limit=0 \
burst-threshold=0 burst-time=0s
dikutip dari blog tetangga unuk disimpan sebagai file data X aja nanti lupa jadi bisa di tengok ulang
http://www.mediacomptech.com/2013/03/high-performance-lusca-squid-proxy.html